Jump to content
Sign in to follow this  
Domino78

Automatic update doesn't work

Recommended Posts

Domino78

Hi everybody,

the automatic update seems not to work on my computer. It says that "No updates available", although the version of the program is still 2.0.0.0... I registered, I have received the key, I have entered it in the Help menu. Do I have to do anything more? Thank you!

Share this post


Link to post
Share on other sites
TjoeTjoe

Hi everybody,

the automatic update seems not to work on my computer. It says that "No updates available", although the version of the program is still 2.0.0.0... I registered, I have received the key, I have entered it in the Help menu. Do I have to do anything more? Thank you!

Braunschweig has never had version number 2.0.0.0 as far as I know.

Could you please check the exact version number again.

I believe the current version should be 2.0.0.43 at the moment.

Share this post


Link to post
Share on other sites
signalsoftRC

At the start screen you should get the message " a new version is available".

if not: go to settings and reset the workplace and updates.

Ensure you're registered and have a VALID license key. License keys from pirate copies don't work ;-) (they're soooo easy to track down ;-))

Share this post


Link to post
Share on other sites
Domino78

if not: go to settings and reset the workplace and updates.

I'll try it tonight.

Ensure you're registered and have a VALID license key. License keys from pirate copies don't work ;-) (they're soooo easy to track down ;-))

I have bought and registered myself, I still have the e-mail with the licence key, it should be VALID... : )

Share this post


Link to post
Share on other sites
Domino78

I'll try it tonight.

... tried, doesn't help.

And yes, it is the version 2.0.0.0 (shown on the top of the About box). The version of the .exe file is also 2.0.0.0 (size: 9.744.384 bytes).

Update of the Settings says "No Updates available", update.exe says "Checking current version..." and freezes.

Share this post


Link to post
Share on other sites
signalsoftRC

your key is ok. I just tested your key myself.

can you start the application as administrator? (try it with the main application as well as the update.exe as administrator. I *think* that's the problem.

Share this post


Link to post
Share on other sites
Domino78

OK., I have just tried. Nothing different. Tried to reinstall, still nothing :-/

I have WinXP Eng. Prof. with SP3.

Share this post


Link to post
Share on other sites
signalsoftRC

ok! very useful information.

i'll try to contact you later directly. Do you have skype?

Share this post


Link to post
Share on other sites
Domino78

ok! very useful information.

If you need more, don't hesitate to ask :)

i'll try to contact you later directly. Do you have skype?

Unfortunately not. You can contact me on MSN sometimes, but nowadays the relation between my "free time" and "Internet access" is rather OR instead of AND :) So I suggest you to contact me on my e-mail address (the one at the gmail).

Share this post


Link to post
Share on other sites
TjoeTjoe

From my personal experience running the Update.exe with Administrator right (instead of updating via its function in the main programm) did solve Update problems if it crashed during update proces in the main programm.

Now, as far as I can remember WinXP (Pro) does not have this extreme User Access Control (UAC) like Vista and Windows7, where you have to run certain programms in Adminstrator right and have to confirm that certain programms are allowd to run.

However, I think even in WinXP Pro you have to make sure that Administrator rights are applied tou your Windows account.

My guess is that that is alll ok, nevertheless, just mentionning it again.

It won't be the first time that something else is blocking thing out of sight. I thinking at the level of firewalls, virusscanners and/or any other security package running on PC's nowadays.

Did you try anything like disabling firewall or virusscanner? Might be worth it.

Last thing what comes to mind is: do you have a boxed version of this simulation (Stellwerk simulator Vol.2 which holds both Hengelo and Braunschweig) or is it just the Braunschweig Hbf download version.

If its is the boxed version then you have two license keys: one for the Hengelo simulation and one for the Braunschweig Hbf simulation. It's important that the right key is activate in the right sim of course.

If it is the download version of Braunschweig, well then we don't have to consider a possible confusion with the license keys of course

I don't know if and how it is possible to detach the license key from the sim. As the last thing I can think of is that the license key activation process has gone wrong somehow. I that case you would want to be able to activate it again.

But honestly I don't know if it is even possible to get in such a situation anyway.

So some suggestions which might hopefully help you solving this issue

Share this post


Link to post
Share on other sites
Domino78

However, I think even in WinXP Pro you have to make sure that Administrator rights are applied tou your Windows account.

Originally I use a limited account, but as soon as I try to update, it sends me a warning message (something in connection with the installing the licence key, I don't remember exactly). So first I have tried to run the program as administrator - did not work. Then I tried to update from an administrator account - did not work.

It won't be the first time that something else is blocking thing out of sight. I thinking at the level of firewalls, virusscanners and/or any other security package running on PC's nowadays.

Did you try anything like disabling firewall or virusscanner? Might be worth it.

I live dangerous :) No virus scanners, and only the standard Windows firewall. Next time I'll try to disable it.

If its is the boxed version then you have two license keys: one for the Hengelo simulation and one for the Braunschweig Hbf simulation. It's important that the right key is activate in the right sim of course.

It is the boxed one. I have registered and received both the keys and the corresponding timetables in e-mail. Does Braunschweig accept Hengelo's key? I will double-check.

Share this post


Link to post
Share on other sites
TjoeTjoe

Originally I use a limited account, but as soon as I try to update, it sends me a warning message (something in connection with the installing the licence key, I don't remember exactly). So first I have tried to run the program as administrator - did not work. Then I tried to update from an administrator account - did not work.

Hmmm, as I said before; running the Update.exe in your Braunschweig folder with Administrator rights should normally work

I live dangerous :) No virus scanners, and only the standard Windows firewall. Next time I'll try to disable it.

It's always worth a try

It is the boxed one. I have registered and received both the keys and the corresponding timetables in e-mail. Does Braunschweig accept Hengelo's key? I will double-check.

It might accept, not sure though, but then for sure it won't work. And in that case, if you assigned the wrong key to a sim, then the next question is, how to get the license removed again. That's something hopefully Richard Plokhaar can tell you, if that's needed anyway

Share this post


Link to post
Share on other sites
Domino78

Meanwhile...

- tried with firewall disabled

- removed the license key, and re-entered (tried with the key of Arnhem and Hengelo too - Braunschweig doesn't accept them)

- tried again, same symptoms: Update.exe hangs up (btw. it doesn't generate one single byte of network traffic); Braunschweig says that last version is installed (sends approx. 0.5kB, receives approx. 2.7kB).

All the steps above performed with Admin rights...

It's a mystery :)

Share this post


Link to post
Share on other sites
Domino78

OFF

Dear Richard, can you contact me on ughyba(at)gmail-dot-com instead of invitel-dot-hu? Currently I have no direct acces to invitel. For the product registration I could use the gmail, but the forum doesn't accept it. Is it possible that the forum has stricter rules?

Thank you in advance.

Share this post


Link to post
Share on other sites
signalsoftRC

try again. should work now.

Share this post


Link to post
Share on other sites
Domino78

Thank you, now i can use the same e-mail address everywhere :)

Is there any news regarding the automatic update problem?

Share this post


Link to post
Share on other sites
TjoeTjoe

Thank you, now i can use the same e-mail address everywhere :)

Is there any news regarding the automatic update problem?

Could you tell us how you are connected to the Internet?

This might sound like a stupid question, but this week I had something similair with Kleinstadt when I was connected to the Internet via (dont tell my boss) the Office network. Kleinstadt reported that no updates were available though I knew that it should upgrade to v100.

In the evening, when I was in the hotel on a public network, started up Kleinstadt again and it started updating immediately.

So the question is, and that's also one for Richard, does the Update mechanism use a specific port to check on the Signalsoft server that an update is available, and if so, which port.

And then the next question would be for you Domino78: is there in anyway a chance that particular ports in your router/modem that connects to the Internet are blocked, and so the simulation can't see that an update is available.

For your information, the above was all on a company laptop with XPProf 32 bit SP3 on it.

And last but not least: if you have by any chance the possibilty to install Skype on your computer, I would strongly recommend doing so and get in touch with Richard via Skype. It will give you direct man-to-man communication, instead off via the slower e-mail of this board

Edit: just wondering. Don't you have similar issues with updating Hengelo and/or Arnhem? Would expect that you would encouter the same problems for those simulations

Share this post


Link to post
Share on other sites
KobaiasoftSupport

Hi Domino78,

I'm the guy who wrote the code for the Update system so I'll see if I can help. Can I send you something by email ?

Share this post


Link to post
Share on other sites
Domino78

Could you tell us how you are connected to the Internet?

Through a WiFi router (with internal IP address).

And then the next question would be for you Domino78: is there in anyway a chance that particular ports in your router/modem that connects to the Internet are blocked, and so the simulation can't see that an update is available.

No - as far as I know.

For your information, the above was all on a company laptop with XPProf 32 bit SP3 on it.

The same here (well, the HW is office, the OS is not... :)

And last but not least: if you have by any chance the possibilty to install Skype on your computer, I would strongly recommend doing so and get in touch with Richard via Skype. It will give you direct man-to-man communication, instead off via the slower e-mail of this board

I have no possibility to use Skype right now. On sunday/monday/tuesday I'll be home, there I will have Skype and different Internet connection (ADSL with external IP addr.).

Actually Richard tried to contact me on my hone e-mail address. I have no direct access to that mailbox, but I received his e-mail automatically forwarded without his e-mail address (stupid Outlook Express), so I could reply only here (see my older post). Since then we did not communicate...

Edit: just wondering. Don't you have similar issues with updating Hengelo and/or Arnhem? Would expect that you would encouter the same problems for those simulations

No idea, since I couldn't find information regarding the last versions of these programs. Is there an official version history for Hengelo and Arnhem?

Share this post


Link to post
Share on other sites
Domino78

Hi Domino78,

I'm the guy who wrote the code for the Update system so I'll see if I can help. Can I send you something by email ?

Hi Charlie,

yes, of course! Please use my gmail address! Thank you!

Share this post


Link to post
Share on other sites
KobaiasoftSupport

Sent.

If you have any problems with the instructions, please email me.

Share this post


Link to post
Share on other sites
KobaiasoftSupport

We were able to get it working for Domino78. There was a rare networking bug that we fixed in the Update tool. Thanks again to Domino78 for his patience and to everyone else who helped with troubleshooting!

Share this post


Link to post
Share on other sites
Domino78

You are welcome! Please don't forget to update the main application too :)

Share this post


Link to post
Share on other sites
Polar_Bear

Hi everyone,

I am a rather new user of SignalSoft simulators. I have bought some of them, including Braunschweig Hbf via the Bundle "Vol. 2" with Hengelo.
Installing the delivered EXE file is fine. It gives me the version 2.0.0 . I am a registered user (key file inserted w/o problem). The simulator runs fine. When starting, it tells me that an update is available.
According to http://www.signalsof...p?showtopic=572 , I have used the "update" tool outside the main programm. It does update the application but then, the simulator crashes when run.
I am using W7 SP1, French version.
Here is the report given by Windows :

-- starts here --

Description :
Stopped working

Signature du problème :
Nom d’événement de problème: CLR20r3
Signature du problème 01: braunschweig hbf.exe
Signature du problème 02: 2.0.0.96
Signature du problème 03: 4d6fefc0
Signature du problème 04: Common
Signature du problème 05: 2.0.0.47
Signature du problème 06: 4d6fef14
Signature du problème 07: fa4
Signature du problème 08: 5a
Signature du problème 09: System.Exception
Version du système: 6.1.7601.2.1.0.256.1
Identificateur de paramètres régionaux: 1036

-- Ends here --

For info, updates of the other PSB simulators I have went just fine everytime I had a notice for update.

Any clue about what is going wrong with that particular one ? Anything I shall check ?

Share this post


Link to post
Share on other sites
Helmut

Hi Polar_Bear,

the topic you are referring to is a very old one.

I have also installed the Braunschweig Sim from the Vol. 2 CD. After starting the programme I updated it by choosing the pop-up link in the start window and it worked very well.

Perhaps you try it again.

Regards

Helmut

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×