Jump to content
Sign in to follow this  
Domino78

Automatic update doesn't work

Recommended Posts

TjoeTjoe

For info, updates of the other PSB simulators I have went just fine everytime I had a notice for update.

Any clue about what is going wrong with that particular one ? Anything I shall check ?

We were able to get it working for Domino78. There was a rare networking bug that we fixed in the Update tool. Thanks again to Domino78 for his patience and to everyone else who helped with troubleshooting!

Salut,

at this moment I think the issue is related to that what code magian Charlie foudn while trying to fix teh update problem for Domino78.

Now I think, as you still have the initial release version, the bug exists in the Update utility.

Therefor, i will forward your message to Charlie. He might get in touch with you by e-mail if he needs more info.

Erwin

Share this post


Link to post
Share on other sites
Polar_Bear

Hi Helmut,

Yes, this is a very old topic but obviously still alive :)

When I am updating from the pop-up link in the start window, it ends with the same result, unfortunately. That is why, after reading this thread, I have also tested via the update tool. No luck.

@Erwin : thanks for your help. On my side, I have also sent a private message to Charlie but I thought it may be interesting for everyone (and any possible new user like me) to know that the possible bug still need to be fixed. Hence my post here.

Share this post


Link to post
Share on other sites
TjoeTjoe

Well, it depends: if your copy is a Boxed version then I can imagine that it is pretty hard to update something which is burned on a DVD :)

Again, for now I am taking this as that you're one of the few lucky ones running into the rate situation not being to update.

Let's wait and see if Charlie can help you any further

Erwin

Share this post


Link to post
Share on other sites
Polar_Bear

A quick update. Charlie has sent me some infos. On my side I have also done my homeworks. It sounds like I have some problems with my .NET 2.0 configuration. Unfortunately, I have not been able to fix it so far so I will remain "not updated" on this one.

Strangely enough, and as I have explained to Charlie, I have the very same problem with the demo version of Amsterdam CS but the full (paid) (and recently updated) version is just running fine ! Go figure...

@Erwin : all my SignalSoft softwares are downloaded ones, no Boxed version on my side.

Share this post


Link to post
Share on other sites
Polar_Bear

Update and an "happy end", rather unexpected.

I have just bought Kirchain (along with Marburg) and when installing, I have been lucky to see the simulation running once but I ended the simulation to install Marburg before registering Kirchain (partly because the default registration screen was writen in Dutch). Marburg started OK, registered OK (despite Dutch screen ;) ), Marburg stopped. I then tried to run Kirchain again and ... got the infamous crash message ("CLR20r3").

To keep a long story short : I have uninstalled Kirchain but also deleting the related folders in (Windows)/User/MyUserName/AppData/Local/SIGNALSOFT_Rail_Consultan. I then installed Kirchain once again, started the sim, registration done, update done and Kirchain still running fine ! That was the clue I needed to fix my problem with Braunschweig ! So I have proceeded the same way : full install (including deleting the folders in AppData), install from scratch and then update to the latest version (v. 2.0.0.96) and ... Braunschweig simulation is now running fine ! B)

Share this post


Link to post
Share on other sites
TjoeTjoe

Salut

you are learning fast on getting things to work when the install went wrong :-)

Good to hear this positive result

Share this post


Link to post
Share on other sites
PeteEHAM

TjoeTjoe,

Maybe we can make this a sticky and/or put it in the Wiki (or maybe it's already there but I didn't see it).

I've had similar problems with reinstalling due to a HDD crash. It's not clear to everyone were files are installed and the uninstaller doesn't uninstall the (Windows)/User/MyUserName/AppData/Local/SIGNALSOFT_Rail_Consultan folder, you have to do that yourself afterwards....

Share this post


Link to post
Share on other sites
signalsoftRC

the french is only available for updates since... I think... Mid May 2014. We're working on an "overall all app" update, except Arnhem. All programs will then be in French available...

Share this post


Link to post
Share on other sites
Polar_Bear

Bon à savoir ! :)

By the way, I have noticed that, on initial install (and this is not directly related to Braunschweig Hbf), even if we choose "English" at first run of the simulation, the menu will still be displayed in Dutch and we have to go to "Simulation/Setting/Language" in order to set it to "English" (and doing so, we can see that the default/current value is set to null/blank). Not really critical, just a bit confusing at first.

Share this post


Link to post
Share on other sites
signalsoftRC

the installer is completely independent from the simulation. So if you choose English for the installer, the sim doesn't know about that.

Normally we assume the "locale" of the computer. But with French computers it might default to "something close". But with the settings you can set it to English.

We can't test it on French computers here... :-)

Share this post


Link to post
Share on other sites
Polar_Bear

Hi Richard,

I was not speaking about the language choosen for the installer but the language choosen when we run the simulation for the first time ;)

And thus, I have faced several times the Dutch version of the registration screen despite the fact that I had well selected "english" a few seconds before when starting the simulation (not the installer). Not a big deal, just a note :)

But I do agree with you : Windows OS and maybe more precisely the French version of it is just Evil :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×